1  1

多多洛

新手上路
发帖:4
回复:0
精华:0
积分:20
金元:4
在线时间:0小时
注册日期:1900-1-1
该帖被浏览 3553 次,回复  0 次   发表于:2012-9-24 11:12

[讨论] jQuery 2.0将不再支持IE 6/7/8相关特性


摘要:jQuery官方发布了下一阶段jQuery的路线图,该路线图显示jQuery 1.8将在一个月内发布。

jQuery官方发布了下一阶段jQuery的路线图,该路线图显示jQuery 1.8将在一个月内发布,而其他后续版本的计划如下:

  • jQuery 1.9:将在2013年初发布,该版本将移除许多在1.8中不建议使用的API,其中一些将作为插件或备选API。该版本仍将支持IE 6/7/8。
  • jQuery 1.9.x:为1.9正式版发布后的修复版本,主要修复发现的bug等。
  • jQuery 2.0:将在2013年初,1.9版本之后不久就会发布,该版本将延续1.9版本所支持的API,但会移除对IE 6/7/8中的相关特性的支持,如事件模型、IE7 “attroperties”以及HTML5 shims框架等。
  • jQuery 1.9和2.0支持相同的API,它们可以互换使用。如果你需要支持IE 6/7/8,那就选择1.9版本;否则,两个版本选择其一即可。


你也可以使用下面的代码:

  • <!- -[if lt IE 9]>
  • <scriptsrc="jquery-1.9.0.js"></script>
  • <![endif]- ->
  • <!--[if gte IE 9]><!- ->
  • <scriptsrc="jquery-2.0.0.js"><</script>
  • <!--<![endif]- ->

1楼  TOP
 1  1